Kawasaki Ninja 300 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I was riding to work and it started and ran perfect. On the last few blocks it started chocking. I could full throttle it, but it would stay around 2k then it would suddenly get fuel. After work I started it up but it wouldn't stay on unless I kept giving it fuel. Also it would stall when I would stop.

Took everything apart. Put in new spark plugs, air filter, cleaned anything. I checked the pump and it was spraying out fuel, spark plugs were working, and the air filter is out so it should be the problem. Still didn't start. I then ordered a new fuel motor and filter. Still would not start. Got a mechanic to take a look to see if it was a fuel pressure issue. He said both pumps are broken... Go figure. Ordered a NEW pump. This one is much more expensive, but it will be here in the week. STILL WOULDN'T START. So less likely I have another bad pump. More likely something else is wrong. I'm thinking the fuel injectors because when I tried to start the bike it was trying to turn over so I checked if the spark plugs are getting fuel and they were not. We put in some ignition into the valves and it started. Also this bike has not been crashed but did tip over once about 6months ago so that shouldn't be the issue.
115282


Thanks!
 

·
Registered
Joined
·
1 Posts
I was riding to work and it started and ran perfect. On the last few blocks it started chocking. I could full throttle it, but it would stay around 2k then it would suddenly get fuel. After work I started it up but it wouldn't stay on unless I kept giving it fuel. Also it would stall when I would stop.

Took everything apart. Put in new spark plugs, air filter, cleaned anything. I checked the pump and it was spraying out fuel, spark plugs were working, and the air filter is out so it should be the problem. Still didn't start. I then ordered a new fuel motor and filter. Still would not start. Got a mechanic to take a look to see if it was a fuel pressure issue. He said both pumps are broken... Go figure. Ordered a NEW pump. This one is much more expensive, but it will be here in the week. STILL WOULDN'T START. So less likely I have another bad pump. More likely something else is wrong. I'm thinking the fuel injectors because when I tried to start the bike it was trying to turn over so I checked if the spark plugs are getting fuel and they were not. We put in some ignition into the valves and it started. Also this bike has not been crashed but did tip over once about 6months ago so that shouldn't be the issue. View attachment 115282

Thanks!
Hey buddy I have a similar problem but mine will start and idles fine when I lean it to the side opposite the kick stand it turns off do uno what this could be ? Thanks
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Hey buddy I have a similar problem but mine will start and idles fine when I lean it to the side opposite the kick stand it turns off do uno what this could be ? Thanks
Sounds more like a tip over sender that's messed up. I'll keep this updated when I figure out more about the bike. I'm about to hook up a Yamaha fuel tank to it and see if its the pump.
 

·
Registered
Joined
·
417 Posts
Do you hear the pump priming when you turn on the ignition?

Fuses all check out?

Vacuum line to the petcock secured and in good cond?

Battery fully charged? If you have cranked a lot without charging it will need it.

When you get it back together and try again, if it doesn't start right away, slowly open the throttle slightly as you crank.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Do you hear the pump priming when you turn on the ignition?

Fuses all check out?

Vacuum line to the petcock secured and in good cond?

Battery fully charged? If you have cranked a lot without charging it will need it.

When you get it back together and try again, if it doesn't start right away, slowly open the throttle slightly as you crank.
Pump is priming and I can hear the injectors. When I'm not working on the bike it's on the trickle charger. Fuses are all good. I'll have to check the other thing. It's been at a mechanics for the past month and 2 of them have no idea what's wrong. In my area they are the best.
 
1 - 8 of 8 Posts
Top