Kawasaki Ninja 300 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
my bike mileage is pretty high, around 40k miles and i’m not too sure about service history as i just got the bike. i’m having a problem with the idle when coming to a stop, it drops to around 1k and sometimes goes back up but sometimes stalls, when i come to a stop and let the bike idle for a minute then rev slightly the bike will stall, could it possibly be valve clearance or maybe dirty fuel injectors? there is a aftermarket exhaust on the bike and the pipe that joins the aftermarket exhaust to the pipe does have a crack so could an air leak in the exhaust mess with the air fuel mixture? any ideas?
 

·
Registered
Joined
·
279 Posts
Have the plugs ever been replaced and has the valve clearance ever been checked?
Those are both waaaay over due at this point.
 

·
Registered
Joined
·
377 Posts
I would start checking things like the air filter, plugs, and valve clearances as suggested.

The injectors could have deposits on them that are effecting the spray. Every year, in every vehicle, I run one tank with a strong fuel system cleaner like Techron Concentrate (1 oz per gal). It cleans deposits from the intake valve stems, combustion chamber, and injectors.

Another thing that can cause that type of issue is old or bad gas. If you let your tank get low often you can get a significant amount of condensation in certain conditions.

The throttle bodies may be out of sync at this point as well.
 
1 - 3 of 3 Posts
Top