Kawasaki Ninja 300 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi everyone!

I have problem with the speedometer. the small display (Multifucntion display) on my bike has no backlight, i can't see anything when riding at night. What should be the problem? Could anyone please help tell me about this? Thanks in advance for your helpful reply.

Best Regards,

Rada
 

Attachments

·
Registered
Joined
·
23 Posts
Hi everyone!

I have problem with the speedometer. the small display (Multifucntion display) on my bike has no backlight, i can't see anything when riding at night. What should be the problem? Could anyone please help tell me about this? Thanks in advance for your helpful reply.

Best Regards,

Rada
new picture would be helpful
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
new picture would be helpful
Hi! Ivy2000100

I guess my image was broken then! what i refer to is the Small display (Fuel Gauge, Speedometer...) it doesn't have the back-light. So i can't read any information when riding the bike at night. Is it because of Fuse or what? Thanks for your reply.

Best Regards

Rada:smile2:
 

·
Registered
Joined
·
23 Posts
Hi! Ivy2000100

I guess my image was broken then! what i refer to is the Small display (Fuel Gauge, Speedometer...) it doesn't have the back-light. So i can't read any information when riding the bike at night. Is it because of Fuse or what? Thanks for your reply.

Best Regards

Rada:smile2:
im thinking either fuse or you damaged a connector somehow.
 

·
Registered
Joined
·
5 Posts
My display, has just done the same thing. the rev's I can see and light up fine the the speed and petrol display, I can not see anything. Is this an easy fix or new display?
 

·
Registered
Joined
·
4 Posts
My display, has just done the same thing. the rev's I can see and light up fine the the speed and petrol display, I can not see anything. Is this an easy fix or new display?
Hey guys,
Any luck with this? I'm having the same issue!
 
1 - 7 of 7 Posts
Top