Kawasaki Ninja 300 Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey everyone, first time poster,
Lately my Kawasaki ninja has been acting weird, I have an aftermarket gear indicator wired in. Sometimes on rides when I start, my battery indicator on the dash comes on and my gear indicator shows an “F”, my dash will also flicker aswell occasionally. As soon as I’m riding there is no problems at all. The only thing is today as I was sitting at a red light in nuetral, my bike cut off, I thought it wouldn’t start again but sure enough first try on the ignition and it turns on as quick as usual, checked the battery, showing 12v, tried checking wiring of the after market gear indicator and seems in tact, I’m so confused what it could be as my battery doesn’t seem to be dying at all. Can anyone help?
 

·
Registered
Joined
·
471 Posts
Hey everyone, first time poster,
Lately my Kawasaki ninja has been acting weird, I have an aftermarket gear indicator wired in. Sometimes on rides when I start, my battery indicator on the dash comes on and my gear indicator shows an “F”, my dash will also flicker aswell occasionally. As soon as I’m riding there is no problems at all. The only thing is today as I was sitting at a red light in nuetral, my bike cut off, I thought it wouldn’t start again but sure enough first try on the ignition and it turns on as quick as usual, checked the battery, showing 12v, tried checking wiring of the after market gear indicator and seems in tact, I’m so confused what it could be as my battery doesn’t seem to be dying at all. Can anyone help?
Sounds like a battery or battery terminal connection issue.

Check that your terminals and ground are snug, and also check your voltage again - 12.0V is a lot lower than it should be after running. 100% charge is 12.7 V, and after running or charging you should see more than that.

If you are getting only 12.0 V you are just over 40% charged and probably need a new battery.
 

·
Registered
Joined
·
12 Posts
Hey everyone, first time poster,
Lately my Kawasaki ninja has been acting weird, I have an aftermarket gear indicator wired in. Sometimes on rides when I start, my battery indicator on the dash comes on and my gear indicator shows an “F”, my dash will also flicker aswell occasionally. As soon as I’m riding there is no problems at all. The only thing is today as I was sitting at a red light in nuetral, my bike cut off, I thought it wouldn’t start again but sure enough first try on the ignition and it turns on as quick as usual, checked the battery, showing 12v, tried checking wiring of the after market gear indicator and seems in tact, I’m so confused what it could be as my battery doesn’t seem to be dying at all. Can anyone help?
Have you disconnected the gear indicator & seen what happens? Just to rule that out?
 
1 - 3 of 3 Posts
Top