Kawasaki Ninja 300 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
387 Posts
Discussion Starter #1
Ok so, I've noticed a few times now after riding the bike that, after shutting her down, the engine oil light comes on.

I'm fairly new to riding but I'm definitely not beating the crap out of it, am shifting fairly well, and keeping things relatively cool and simple with the bike.

What am I doing wrong??

Feedback definitely appreciated.
 

·
Registered
Joined
·
198 Posts
Mine has come on once when switching it off, not %100 sure.
I'm getting my first service done soon and il ask the mechanic and get back to you!
Not think its anything to worry about, my abs light stays on for 1 minute once started aswell!
 

·
Registered
Joined
·
387 Posts
Discussion Starter #3
Thanks I appreciate it. I wonder if it's just because it's such a new bike (i haven't even crossed a hundred miles, had to put it away for Hurricane Sandy)
 

·
Registered
Joined
·
387 Posts
Discussion Starter #5
I don't think so, maybe i'm wrong
 

·
Registered
Joined
·
2,760 Posts
if you use the kill switch then you are killing the engine and leaving the electronics on.. if you kill the engine there is no oil pressure so that turns the light on..
 

·
Registered
Joined
·
294 Posts
agree, this light is normal, to be on when the engine is off, think about it, its a sensor for oil pressure, and is to be triggered if the pressure is too high or too low. kill the engine and it pops on, its just doing its job. If the engine is running, and that light comes on, pull over immediately and have the bike taken to shop, thats a no no
 
1 - 8 of 8 Posts
Top