Kawasaki Ninja 300 Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,231 Posts
Discussion Starter #1
As most of you know their is a forum special on this camera. I started reading the reviews of this camera and they are mostly horrible. Can any owners verify that the freezing issue is taken care of. Also what is the battery life when not using wifi?


Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
279 Posts
From what i've read, it looks like the freezing issue was only in the first batch of cameras that were released. As far as the battery life w/o the wifi, I think it's close to an hour. Only real downside honestly.
 

·
Registered
Joined
·
1,231 Posts
Discussion Starter #3
I did read their was a firmware update that solved the crash. I guess some people don't update.


Sent from Motorcycle.com Free App
 

·
Super Moderator
Joined
·
1,075 Posts
Yup. Mine had freezing issues. Got mine for christmas. Since the recent update. I've had 0 issues :)
 

·
Registered
Joined
·
561 Posts
i had the gp3 black when it first came out. the update did nothing for me, still froze everytime I used it. I don't have it anymore dropped it in the ocean last week UGH!!! and it had my LCD screen on it to $500+ down the drain.

But anyways I did end up finding a fix for the freeze up issue. the freezing was caused by one of the recording modes when powered on. what you need to do is set it up so that your camera is on first when powered up not the recorder. never had a problem after that, until i lost it.... lol...
 

·
Registered
Joined
·
38 Posts
The thing does eat up the battery but the videos are amazing. Buy the fastest SD cards available.

No freezing on mine but I am to date on firmware.
 

·
Super Moderator
Joined
·
1,075 Posts
i had the gp3 black when it first came out. the update did nothing for me, still froze everytime I used it. I don't have it anymore dropped it in the ocean last week UGH!!! and it had my LCD screen on it to $500+ down the drain.

But anyways I did end up finding a fix for the freeze up issue. the freezing was caused by one of the recording modes when powered on. what you need to do is set it up so that your camera is on first when powered up not the recorder. never had a problem after that, until i lost it.... lol...
Screw that! I would have went in for it!!
 
1 - 10 of 10 Posts
Top