Kawasaki Ninja 300 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
322 Posts
Discussion Starter #1
Hi all,

Just got done my first "real" mode - Some of you may have saw I was selling my Targa fender eliminator the other day. Anyways, I realized I COULD actually use the turn indicators it came with as I didn't order the LED kit! :cool:
So I got it on with the help of the DIY thread here, took 30 minutes! Stoked!
The only negative now is that my signals blink slightly faster than what the OEM's blinked, and the indicator on my cluster seems to "lag" for a second when I first flip on the signal. Not sure if I do actually need some sort of new relay to plug in or not ?? Any suggestions?



Because to Targa comes with new mounting bolts for the fender, it left me with the 4 OEM bolts that were under the trunk ! So, I now had no excuse not to remove those front reflectors!!


Quick shot of the cluster with my new key tag :)



The Plasti-Dip on my wheels doesn't look the most incredibly. I mean, I love how it looks from a distance and especially while moving - looks wicked. But up close you can really tell it's plasti-dip and it's peeling in places.
I've got some thick rim tape ordered that I might replace with once it arrives. It's the same color, "florescent yellow" ;)
Also have some cheap green ebay levers on their way! I ended up ordering the longer OEM length ones, because I actually really like the current feel!
 

·
Registered
Joined
·
4,130 Posts

·
Registered
Joined
·
1,368 Posts
Thanks guys :) I'm pretty happy with it.
Any idea where I could find a 2 pin flasher relay? I figure some local parts stores might have something, wouldn't hurt to check them out.

Here's what I've ordered to replace my plasti-dip when I get sick of it and peel it off..
That's awesome. Is it a tape or what is it?

Sent from Motorcycle.com Free App
 
1 - 8 of 8 Posts
Top