Kawasaki Ninja 300 Forums banner

problem

  1. FYI: Battery Tender Junior/Battery Tender USB port

    Ninja 300 Parts & Accessories
    Hello all - Just wanted to post a quick informational post. I installed a Battery Tender Quick Connect cable on my 300. Ran the cable from the battery up the left side of the chassis behind the fairings and mounted the end of the cable to the underside of the left handgrip. The original cable...
  2. Ninja 300 doesn't start after installing motodynamic integrated tail light - electric

    Ninja 300 Issues and Troubleshooting
    RESOLVED So I just installed the motodynamic integrated tail light -- checked everything and it all worked perfectly. Bolted the ninja back together. Took it for an hour ride. Parked it as I always do. Next day it just makes this sound and does not start. . I disconnected the tail light but i...
  3. Chain issue?

    Ninja 300 General Discussion
    Hi everyone, A few weeks ago I've been noticing a jitter (if that's the correct word for it) when i'm accelerating and decelerating. Instead of a constant acceleration its like taking little steps or pushes as I go faster/slower and its annoying me but more than that's its worrying me. Its my...
  4. Metallic sound to engage

    Ninja 300 Issues and Troubleshooting
    Hi guys, recently i have a problem whit my ninja, its just a sound in the moment to engage.. sorry but my inglish is bad.. here a video with the problem Any idea what may be going? Thanks!
  5. So I messed up - *Electrical*

    Ninja 300 Issues and Troubleshooting
    Yesterday and today I have been replacing my head bearings with tapered ones from Pyramid. I was putting it all back together and must have tugged on the wiring a little too much and am now having intermittent electrical issues. I have traced it down to one cluster of wires, the ones that run to...
Top