Kawasaki Ninja 300 Forum - Reply to Topic
Thread: Rear Break feels weak & doesn't work Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Kawasaki Ninja 300 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
07-13-2019 06:58 PM
jkv45
Quote:
Originally Posted by SparkyMJ View Post
I typically notice just poor brake performance on unkempt rear brakes, but you could have a leak or a lot of air. Check the bleeder nut on the caliper for good sealing and being tightened all the way (but don't crank it, its a gentle tight).

After that, consider your actual caliper health, it could be improperly seated, allowing a sort of "springing" due to misfitted parts.

So brake calipers by design are a 'floating' system, they can move, they have to move in certain directions during use and wear to stay a good tight fit against the rotors. If you go wiggle your actual caliper, it will move a bit. The caliper itself has 2 smooth metal pins that the caliper slides upon, and me being lazy in the brake job didn't take them out, just threw in new pads. Bad choice. Turns out the sliding motion of the caliper along those pins was not allowed at all, because the pins had dry grime totally seizing them in position. Completely solved this problem by removing the pins (with quite some force) fully cleaning them with rubbing alcohol, and applying fresh brake grease. Made my rear brake go from just about zero effectiveness to 100% instantly.

Id check your fluid levels as mentioned before, and check your lines. then lastly, Id check your actual brake pads, rotors, and the caliper and its pistons. Definitely worth the full tear down when I did my brake job, and I couldn't be happier with my new pads, fresh fluid, and freshly greased parts. If I was you, I would tear the whole system down and clean it up and inspect it if you're up to the task.

Hope that helps a bit.
-Mike
Absolutely critical when doing any work on the brakes.

Some more info from Ninja250.org - https://faq.ninja250.org/wiki/How_do..._brake_pads%3F
07-13-2019 05:51 AM
SparkyMJ I typically notice just poor brake performance on unkempt rear brakes, but you could have a leak or a lot of air. Check the bleeder nut on the caliper for good sealing and being tightened all the way (but don't crank it, its a gentle tight).

After that, consider your actual caliper health, it could be improperly seated, allowing a sort of "springing" due to misfitted parts.

So brake calipers by design are a 'floating' system, they can move, they have to move in certain directions during use and wear to stay a good tight fit against the rotors. If you go wiggle your actual caliper, it will move a bit. The caliper itself has 2 smooth metal pins that the caliper slides upon, and me being lazy in the brake job didn't take them out, just threw in new pads. Bad choice. Turns out the sliding motion of the caliper along those pins was not allowed at all, because the pins had dry grime totally seizing them in position. Completely solved this problem by removing the pins (with quite some force) fully cleaning them with rubbing alcohol, and applying fresh brake grease. Made my rear brake go from just about zero effectiveness to 100% instantly.

Id check your fluid levels as mentioned before, and check your lines. then lastly, Id check your actual brake pads, rotors, and the caliper and its pistons. Definitely worth the full tear down when I did my brake job, and I couldn't be happier with my new pads, fresh fluid, and freshly greased parts. If I was you, I would tear the whole system down and clean it up and inspect it if you're up to the task.

Hope that helps a bit.
-Mike
07-08-2019 04:26 PM
IronWarrior With no other information (and assuming you have confirmed pushing the pedal does not engage the brakes), my first two guesses would be low fluid level (maybe caused by worn pads or a leak) or air in the lines. I'd first check for leaks, fluid level, and pad thickness, if that's all good my next step would be bleeding the system.
07-08-2019 10:44 AM
jkv45 Look through this section for info on the brake system, problem diagnosis, and repair - https://faq.ninja250.org/wiki/Brakes

It's not super complicated to work on, but some tools, patience, and mechanical knowledge are required.

Last season I had the rear brake of my SV stop working. After flushing and bleeding the system it has been fine. The rear brake should be used mostly as a supplement to the front brake - but it needs to work properly.
07-08-2019 09:45 AM
Granpooba
Quote:
Originally Posted by Solar7 View Post
My rear break has no push to it just drops and springs up. It doesn't work & I have no idea what to look at, what to check & how to identify the cause.

Please help.

Kind Regards

Michael

It sounds like you may be at a complete loss as to how the rear brake system works. But that is OK, as many other's suffer from such loses, including myself at times.


But the very first thing that I would " Personally " do is refer to the owners manual. Their I would locate the description and location of the rear brake reservoir. CHECK, to make sure that your brake fluid is up to the proper lever. I would say that if you have fluid and its level is OK, then you have other problems. One may be that you have air in the system and it needs bleeding. If that is the case and I was YOU, I would have a motorcycle tech do the work and check out the system.


It is relatively a simple system and your problem should be easily solved. Until it is, only use the front brake.
07-08-2019 08:27 AM
Solar7
Rear Break feels weak & doesn't work

My rear break has no push to it just drops and springs up. It doesn't work & I have no idea what to look at, what to check & how to identify the cause.

Please help.

Kind Regards

Michael

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome