Kawasaki Ninja 300 Forum

Kawasaki Ninja 300 Forum (https://www.kawasakininja300.com/forum/)
-   Ninja 300 General Discussion (https://www.kawasakininja300.com/forum/8-ninja-300-general-discussion/)
-   -   Rear Break feels weak & doesn't work (https://www.kawasakininja300.com/forum/8-ninja-300-general-discussion/135033-rear-break-feels-weak-doesnt-work.html)

Solar7 07-08-2019 07:27 AM

Rear Break feels weak & doesn't work
 
My rear break has no push to it just drops and springs up. It doesn't work & I have no idea what to look at, what to check & how to identify the cause.

Please help.

Kind Regards

Michael

Granpooba 07-08-2019 08:45 AM

Quote:

Originally Posted by Solar7 (Post 1709927)
My rear break has no push to it just drops and springs up. It doesn't work & I have no idea what to look at, what to check & how to identify the cause.

Please help.

Kind Regards

Michael


It sounds like you may be at a complete loss as to how the rear brake system works. But that is OK, as many other's suffer from such loses, including myself at times. :surprise:


But the very first thing that I would " Personally " do is refer to the owners manual. Their I would locate the description and location of the rear brake reservoir. CHECK, to make sure that your brake fluid is up to the proper lever. I would say that if you have fluid and its level is OK, then you have other problems. One may be that you have air in the system and it needs bleeding. If that is the case and I was YOU, I would have a motorcycle tech do the work and check out the system.


It is relatively a simple system and your problem should be easily solved. :smile2: Until it is, only use the front brake. :wink2:

jkv45 07-08-2019 09:44 AM

Look through this section for info on the brake system, problem diagnosis, and repair - https://faq.ninja250.org/wiki/Brakes

It's not super complicated to work on, but some tools, patience, and mechanical knowledge are required.

Last season I had the rear brake of my SV stop working. After flushing and bleeding the system it has been fine. The rear brake should be used mostly as a supplement to the front brake - but it needs to work properly.

IronWarrior 07-08-2019 03:26 PM

With no other information (and assuming you have confirmed pushing the pedal does not engage the brakes), my first two guesses would be low fluid level (maybe caused by worn pads or a leak) or air in the lines. I'd first check for leaks, fluid level, and pad thickness, if that's all good my next step would be bleeding the system.

SparkyMJ 07-13-2019 04:51 AM

I typically notice just poor brake performance on unkempt rear brakes, but you could have a leak or a lot of air. Check the bleeder nut on the caliper for good sealing and being tightened all the way (but don't crank it, its a gentle tight).

After that, consider your actual caliper health, it could be improperly seated, allowing a sort of "springing" due to misfitted parts.

So brake calipers by design are a 'floating' system, they can move, they have to move in certain directions during use and wear to stay a good tight fit against the rotors. If you go wiggle your actual caliper, it will move a bit. The caliper itself has 2 smooth metal pins that the caliper slides upon, and me being lazy in the brake job didn't take them out, just threw in new pads. Bad choice. Turns out the sliding motion of the caliper along those pins was not allowed at all, because the pins had dry grime totally seizing them in position. Completely solved this problem by removing the pins (with quite some force) fully cleaning them with rubbing alcohol, and applying fresh brake grease. Made my rear brake go from just about zero effectiveness to 100% instantly.

Id check your fluid levels as mentioned before, and check your lines. then lastly, Id check your actual brake pads, rotors, and the caliper and its pistons. Definitely worth the full tear down when I did my brake job, and I couldn't be happier with my new pads, fresh fluid, and freshly greased parts. If I was you, I would tear the whole system down and clean it up and inspect it if you're up to the task.

Hope that helps a bit.
-Mike

jkv45 07-13-2019 05:58 PM

Quote:

Originally Posted by SparkyMJ (Post 1710001)
I typically notice just poor brake performance on unkempt rear brakes, but you could have a leak or a lot of air. Check the bleeder nut on the caliper for good sealing and being tightened all the way (but don't crank it, its a gentle tight).

After that, consider your actual caliper health, it could be improperly seated, allowing a sort of "springing" due to misfitted parts.

So brake calipers by design are a 'floating' system, they can move, they have to move in certain directions during use and wear to stay a good tight fit against the rotors. If you go wiggle your actual caliper, it will move a bit. The caliper itself has 2 smooth metal pins that the caliper slides upon, and me being lazy in the brake job didn't take them out, just threw in new pads. Bad choice. Turns out the sliding motion of the caliper along those pins was not allowed at all, because the pins had dry grime totally seizing them in position. Completely solved this problem by removing the pins (with quite some force) fully cleaning them with rubbing alcohol, and applying fresh brake grease. Made my rear brake go from just about zero effectiveness to 100% instantly.

Id check your fluid levels as mentioned before, and check your lines. then lastly, Id check your actual brake pads, rotors, and the caliper and its pistons. Definitely worth the full tear down when I did my brake job, and I couldn't be happier with my new pads, fresh fluid, and freshly greased parts. If I was you, I would tear the whole system down and clean it up and inspect it if you're up to the task.

Hope that helps a bit.
-Mike

Absolutely critical when doing any work on the brakes.

Some more info from Ninja250.org - https://faq.ninja250.org/wiki/How_do..._brake_pads%3F


All times are GMT -4. The time now is 09:36 PM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome