Horn doesn't work - Kawasaki Ninja 300 Forum
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 08-16-2014, 06:21 PM Thread Starter
Banned
 
Join Date: Feb 2013
Posts: 613
Thanks: 25
Thanked 129 Times in 105 Posts
Horn doesn't work

Has anyone else have issues with their horn not working? I tried to use mine today and all it does is make a pinging noise barely noticable at idle with my helmet off.
chevyguy4321 is offline  
post #2 of 6 (permalink) Old 08-16-2014, 07:09 PM
Seasoned Vet
 
Join Date: Jun 2014
Location: Sacramento, CA
Posts: 996
Thanks: 22
Thanked 379 Times in 272 Posts
Check the horn (right in front of the radiator) for any visible damage, if it makes any noise at all then the switch/wiring are probably ok, which leaves only the horn itself. Maybe it got smacked by a rock or something? Could be a good excuse to upgrade the horn to sound less like a toy and more like a freight train, lol.

White 2014 Ninja 300 SE ABS: Pirelli Diablo Rosso IIs (stock sizes), Power Commander V (fuel and ignition), K&N filter, Yoshimura R-77 carbon fiber full exhaust, adjustable rearsets, 15w fork oil
twistywrist is offline  
post #3 of 6 (permalink) Old 08-16-2014, 09:19 PM Thread Starter
Banned
 
Join Date: Feb 2013
Posts: 613
Thanks: 25
Thanked 129 Times in 105 Posts
No it doesn't look damaged. Luckly I have a spare off my L1 GSXR 750. Seems too look like the exact same horn.
chevyguy4321 is offline  
post #4 of 6 (permalink) Old 08-17-2014, 04:52 AM
Forum Champion
 
FreelancerMG's Avatar
 
Join Date: Feb 2013
Location: SoCal
Posts: 3,516
Thanks: 363
Thanked 1,661 Times in 1,049 Posts
Garage
Check to make sure nothing crawled up and is jammed in the diaphragm or blocking the armature. Sometimes small bugs or dirt and dust accumulation may prevent the diaphragm or armature from moving when power is applied and you get more of a pitiful tap than a honk. Also make sure that the wiring isn't fried. Horns take a lot of power and some old or poorly connected lines wont send enough power to the horn to fully vibrate the diaphragm.

2017 Black FZ-10
FreelancerMG is offline  
post #5 of 6 (permalink) Old 08-17-2014, 09:59 AM Thread Starter
Banned
 
Join Date: Feb 2013
Posts: 613
Thanks: 25
Thanked 129 Times in 105 Posts
Wirings fine but I'll check for obstruction today
chevyguy4321 is offline  
post #6 of 6 (permalink) Old 08-17-2014, 02:23 PM Thread Starter
Banned
 
Join Date: Feb 2013
Posts: 613
Thanks: 25
Thanked 129 Times in 105 Posts
So I looked and I coudn't find anything. I went to show my brother the horn and it worked. Well just once. Not sure whats going on with it but I'm replacing it with the gsxr's
chevyguy4321 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Ninja 300 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Louder 139dB horn or stock horn? Ninjatenza Ninja 300 Appearance & Modifications 17 08-01-2014 10:59 AM
Horn not working. raptorstewie Ninja 300 Issues and Troubleshooting 12 02-11-2014 11:56 PM
Accidental Horn-Honking Dezagon Ninja 300 General Discussion 31 01-16-2014 04:36 PM
Freeway Blaster Horn Bill Ninja 300 Parts & Accessories 7 10-09-2013 04:24 PM
Direct Replacement Horn?? wisemonkey1 Ninja 300 Parts & Accessories 11 02-05-2013 03:03 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome