I need advice please - Kawasaki Ninja 300 Forum
 1Likes
  • 1 Post By jkv45
 
LinkBack Thread Tools
post #1 of 9 (permalink) Old 08-23-2019, 10:42 AM Thread Starter
Junior Member
 
Join Date: May 2019
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
I need advice please

My co-worker gave me his ninja that's been sitting for a few years. Got a new battery, changed fuel pump, checked fuzes. Bike lights up, cranks but won't start. Where is the ignition coil. I need to check for spark. Any suggestions welcome .
IShacka is offline  
post #2 of 9 (permalink) Old 08-23-2019, 10:51 AM
Veteran
 
Join Date: Jul 2018
Posts: 286
Thanks: 7
Thanked 13 Times in 13 Posts
If the fuel wasn't treated, most likely there's still bad fuel in the lines and it has gummed-up the injector.

Be sure to charge the battery between attempts.

A strong fuel system cleaner might clear it out eventually if you can get it to run at all.
jkv45 is offline  
post #3 of 9 (permalink) Old 08-23-2019, 12:28 PM Thread Starter
Junior Member
 
Join Date: May 2019
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Thx for the advice. Do you know where the ignition coil is located?
IShacka is offline  
post #4 of 9 (permalink) Old 08-23-2019, 12:59 PM
Veteran
 
Join Date: Jul 2018
Posts: 286
Thanks: 7
Thanked 13 Times in 13 Posts
Quote:
Originally Posted by IShacka View Post
Thx for the advice. Do you know where the ignition coil is located?
I wouldn't bother testing the coil at this point - but you could just follow the plug wire.

Chances are the ignition and plugs are fine, most likely a fuel-related issue from sitting.

What year and how many miles? Have you checked the air filter and airbox for critters or restrictions?

It has the original ignition switch and key, right?

Post a video of it if you can.
jkv45 is offline  
post #5 of 9 (permalink) Old 08-23-2019, 04:24 PM Thread Starter
Junior Member
 
Join Date: May 2019
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
We were given a used ignition and key
IShacka is offline  
post #6 of 9 (permalink) Old 08-23-2019, 06:12 PM
Veteran
 
Join Date: Jul 2018
Posts: 286
Thanks: 7
Thanked 13 Times in 13 Posts
Quote:
Originally Posted by IShacka View Post
We were given a used ignition and key
Ah...was it a factory ignition or a replacement?

Replacement ignitions lack a resistor, and don't allow full voltage to get to the coils (or something like that) - so it will crank but not start.

If it's a OEM ignition, I would check around for the location of the resistor and confirm it's in place.
MAL likes this.
jkv45 is offline  
post #7 of 9 (permalink) Old 08-24-2019, 12:27 PM Thread Starter
Junior Member
 
Join Date: May 2019
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Is there any way you could help me out with aftermarket ignition resister issue
IShacka is offline  
post #8 of 9 (permalink) Old 08-24-2019, 01:27 PM
jkv45 is offline  
post #9 of 9 (permalink) Old 08-24-2019, 01:38 PM Thread Starter
Junior Member
 
Join Date: May 2019
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Bless u
IShacka is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Ninja 300 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn signals DIED. What? Advice, please... bodhipooh Ninja 300 General Discussion 24 06-12-2017 07:28 PM
Need advice please; accident, repairs Stefan New South Wales 5 03-18-2016 08:14 AM
Ninja 300 Advice Please x DerViisH Ninja 300 General Discussion 19 02-05-2015 03:18 PM
Too Tall For Ninja 300? Advice Please Zarslanian Ninja 300 General Discussion 13 08-15-2014 04:17 PM
Need help determining upgrade, need advice on 848 Evo Khanman Ex-300 Riders 12 04-30-2014 12:13 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome